Beginning in January 2017 Roland has upgraded the IC Chip that resides on EUV, EUV3, ECO-SOL MAX, ECO-SOL MAX2, and SBL2 ink cartridges. In order for Roland machines to recognize the ink cartridges after the upgrade, Roland operators will need to update their machines firmware to the latest version. You can find a link to the latest version of your machines firmware below, and the minimum version required to ensure your ink cartridges are recognized by the printer.

LEF-20 Ver.1.80 and later: Link here

LEF-12 Ver.2.20 and later: Link here

LEJ-640 Ver.2.20 and later: Link here

LEC-300/300A/330/540 Ver.6.40 and later: Link here

XF-640 Ver.2.10 and later: Link here

XR-640 Ver.1.50 and later: Link here

RF-640/640A Ver.1.30 and later: Link here

VS-640i/540i/300i Ver.1.30 and later: Link here

VS-640/540/420/300 Ver.4.60 and later: Link here

SP-540i/300i Ver.2.20 and later: Link here

BN-20 Ver.2.20 and later: Link here

XC-540 Ver.4.40 and later: Link here

RE-640 Ver.1.90 and later: Link here

VP-540i/300i Ver.4.70 and later:  Link here  

VP-540/300 Ver.4.70 and later:  Link here

RS-640/540 Ver.4.70 and later:  Link here

SJ-1000/1045EX Ver.2.90 and later: Link here

SP-540V/300V/300 Ver.7.40 and later: Link here

FP-740 ver 2.9 and later PLUS the bulk ink  BU-1 Ver. 6.01 and later: Link here

For more information or help in updating your firmware, you can contact the GSG Digital Service department by calling 214-712-6284 or e-mailing Digital.Service@gogsg.com.